Skip to content
Index General Talk Faucet Discussion

~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes

Posted by speedup-faucet.com 1 year ago
48 18014
Level 102
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 2 months ago
why my email does not receive confirmation to update my wallet addresses
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 2 months ago
can't save addr wallet...& make can't wd
Level 3
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 2 months ago
still the wallet setting page not working :(
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 2 months ago
Yesterday didn't receive mail, and today when I tried to update wallets, I got 500 Internal Server Error.
Level 83
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 2 months ago
I like the new site but, it is riddled with missing captcha's and redirects to porn sites, which I do not like since I have kids, and do not want that stuff popping up on screen. Can you please fix this?
Level 36
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 2 months ago
after the new password is setup ,I am unable to log in. I even attempted to retrieve from email to reset but your retrieval email is also down. Please look into this thanks!
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 1 month ago
MR or ADMIN Remove Cut-urls and earnesia shortlinks they are not working...failing all the time and it would be as if is someone that fail to pass them...always test your shortlinks daily
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 13 days ago
Vivads not workin,just popads,no clickable link. I cant continue the sortlinks,delete or fix this vivads please.
RE: ~SPEEDUP FAUCET~ Claim BTC, DOGE, LTC & ETH Every 10 Minutes
Posted 3 days ago, last edited 3 days ago
Short.pe is not working for me -> changing to website "healthtykk com/wordpress/ " with message "Error establishing a database connection". Two claims left of one amount of tokens and I can't do anything - I had only this one site. What happened? How I can fix it? It's little bit annoying...